Dalam dunia networking kita pasti juga akan menemukan istilan Load Balance. Sesuai namanya, Load berarti beban sedangkan Balance berarti seimbang. atau dapat kita sebut menyeimbangkan beban. Secara teknik Load Balance adalah  suatu teknik untuk menyeimbangkan traffic
load atau beban data kedalam beberapa link atau jalur denagn tujuan tidak ada jalur yang lebi terbebani.
Biasanya kita sering menjumpai teknik ini dalam pembagian jalur koneksi dengan melalui dua buah ISP. Namun, sebagai permulaan kita akan membahas teknik Load Blance dalan suatu jaringan LAN terlebih dahulu.
Perhatikan Gambar Berikut.

Berdasarkan gambar diatas, baik Mikrotik2 dan Mikrotik3 akan terhubung melalui dua buah jalur koneksi yaitu melalui network 192.168.1.0/24 dan network 192.168.3.0/24. Kedua jalur ini yang nantinya digunakan Host1 untuk berkomunikasi ke Host2 ataupun sebaliknya.
Pada teknik Load Balance juga dikenal teknik ECMP (Equal Cost Multi Path), yaitu suatu teknik memasangkan dua atau lebih gateway untuk menuju kesuat unetwork tertentu.
Baiklah, dalam pengkonfigurasiannya berikut langkah langkahnya, disini saya menggunakan Tool Simulator GNS3.
Langkah #1 : Bentuk Topologi seperti gambar diatas.
Langkah #2 : Tambahkan IP pada masing masing Interface Pada Setipa Route (lihat gambar).

  • Mikrotik1
[admin@MikroTik] > /ip add add add=192.168.11.66/24 interface=ether1
[admin@MikroTik] > /ip add add add=192.168.1.1/24 interface=ether2
[admin@MikroTik] > /ip add pr
Flags: X – disabled, I – invalid, D – dynamic
#   ADDRESS            NETWORK         INTERFACE
0   192.168.11.66/24   192.168.11.0      ether1
1   192.168.1.1/24      192.168.1.0        ether2
  • Mikrotik2
[admin@MikroTik] > /ip add add add=192.168.1.2/24 interface=ether1
[admin@MikroTik] > /ip add add add=192.168.100.1/24 interface=ether2
[admin@MikroTik] > /ip add add add=192.168.2.1.66/24 interface=ether3
[admin@MikroTik] > /ip add pr
Flags: X – disabled, I – invalid, D – dynamic
#   ADDRESS            NETWORK         INTERFACE
0   192.168.1.2/24     192.168.1.0         ether2
1   192.168.2.1/24     192.168.2.0         ether1
2   192.168.100.1/24   192.168.100.0   ether3
[admin@MikroTik] >
  • Mikrotik3
[admin@MikroTik] > /ip add add add=192.168.1.3/24 interface=ether1
[admin@MikroTik] > /ip add add add=192.168.200.1/24 interface=ether2
[admin@MikroTik] > /ip add add add=192.168.2.2/24 interface=ether3
[admin@MikroTik] > /ip add pr
Flags: X – disabled, I – invalid, D – dynamic
#   ADDRESS            NETWORK         INTERFACE
0   192.168.1.3/24     192.168.1.0         ether2
1   192.168.2.2/24     192.168.2.0         ether1
2   192.168.200.1/24   192.168.200.0   ether3
[admin@MikroTik] >

Langkah #3 : Masukkan Konfigurasi Dasar Mikrotik pada Mikrotik1 agar anda bisa terkoneksi ke Internet, Disini saya menggunakan gateway 192.168.11.50

[admin@MikroTik] > /ip route add dst-address=0.0.0.0/0 gateway=192.168.11.50
[admin@MikroTik] > /ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

Langkah #4 : Buat Routing Static pada setiap Router untuk dapat berkomunikasi satu sama lain.

  • Mikrotik1
[admin@MikroTik] > /ip route add dst-address=192.168.200.0/24 gateway=192.168.1.3
[admin@MikroTik] > /ip route add dst-address=192.168.100.0/24 gateway=192.168.1.2
  • Mikrotik2
[admin@MikroTik] > /ip route add dst-address=192.168.200.0/24 gateway=192.168.1.3,192.168.2.2
[admin@MikroTik] >
  • Mikrotik3 
[admin@MikroTik] > /ip route add dst-address=192.168.100.0/24 gateway=192.168.1.2,192.168.2.1
[admin@MikroTik] >

Langkah #4 : Sampai pada tahap ini konfigurasi telah selesai, kini anda sudah punya dua buah jalur/link.

Sedikit tambahan, pada teknik Load Balancing with ECMP ini anda akan menggunakan prinsip Round Robin. Prinsip Round Robin yaitu prinsip yang mengalirkan sebuah traffic data ke jalur/link yang lain jika link dirinya telah berada dalam posisi sangat terbebani.
Dalam teknik Load Balance dipakai juga teknik Fail Over. Namun saya aka nmembahasany pada posting selanjutnya.
Sekian dan Terima kasihh

Azhari Sikumbang

Tulis dan bicarakan, agar lebih berguna. (Github | Linked in)
~ azhari@coretanit.com