Konfigurasi Routing OSPF Pada Mikrotik. OSPF merupakan singkatan dari Open Shortest Part First adalah sebuah protokol yang bersifat dinamis, OSPF akan mengikuti setiap alur dari router yang paling pendek.
Artinya antar setiap router akan terjadi interaksi untuk mengecek mana jalur paling pendek dan teraman. Cukup basa basinya hehe ntar agan tambah pusing dengan penjelasannya. YOk ke TKP…….

Konfigurasi Routing OSPF

Persiapan awal yang harus anda lakukan adalah melakukan topologi seperti berikut… jangan pusing gan hehehe

Jika, kita perhatikan secara detail gambar topologi diatas, OSPF nya terjadi pada R-1, R-2, R-3 . Yaitu

Setiap router ini akan selalu melakukan interaksi menanyakan mana jalur terpendek dan teraman menuju kearah tujuannya nanti. Langsung saja ke tkp konfigurasi ospf.

  • Router 1 / R-1 : Penambahan IP Address untuk setiap interfaces

[admin@MikroTik] > /ip add add add=192.168.18.194/24 interface=ether0
[admin@MikroTik] > /ip add add add=10.10.1.1/24 interface=ether1
[admin@MikroTik] > /ip add add add=10.10.3.1/24 interface=ether3

  • Router 2 / R-2 : Penambahan IP Address Untuk Setiap Interfaces

[admin@MikroTik] > /ip add add add=192.168.14.2/24 interface=ether0
[admin@MikroTik] > /ip add add add=10.10.1.2/24 interface=ether1
[admin@MikroTik] > /ip add add add=10.10.2.1/24 interface=ether2

  • Router 3 / R-3 : Penambahan IP Adrress Untuk Setiap Interfaces 

[admin@MikroTik] > /ip add add add=192.168.15.1/24 interface=ether0
[admin@MikroTik] > /ip add add add=192.168.17.1/24 interface=ether1
[admin@MikroTik] > /ip add add add=192.168.16.1/24 interface=ether4
[admin@MikroTik] > /ip add add add=10.10.2.2/24 interface=ether2
[admin@MikroTik] > /ip add add add=10.10.3.2/24 interface=ether3

Setelah Kita menambahkan IP Addres pada setiap Interfaces, kita juga masih harus membaut sebuah interfaces loopbak beserta ip nya.

  • Router 1 / R-1 : Pembuatan Interfaces Loopback Dan IP Address

[admin@MikroTik] > /int bridge add name=loopback
[admin@MikroTik] > /ip add add add=1.1.1.1/32 interface=loopback

  • Router 2 / R-2 : Pembuatan Interfaces Loopback Dan IP Address  

[admin@MikroTik] > /int bridge add name=loopback
[admin@MikroTik] > /ip add add add=2.2.2.2/32 interface=loopback

  • Router 3 / R-3 : Pembuatan Interfaces Loopback Dan IP Address  

[admin@MikroTik] > /int br add name=loopback
[admin@MikroTik] > /ip add add add=3.3.3.3/32 interface=loopback

Selanjutnya adalah mengaktifkan OSPF Instance, caranya

  • Router 1 / R-1 : Mengaktifan OSPF Instance 

[admin@MikroTik] > /routing ospf instance set 0 router-id=1.1.1.1 distribute-default=always-as-type-1

  • Router 2 / R-2 : Mengaktifan OSPF Instance  

[admin@MikroTik] > /routing ospf instance set 0 router-id=2.2.2.2 distribute-default=always-as-type-1

Catatan : Router-ID disisikan dengan IP Loopback dan always-as-type-1 diberikan pada setiap router yang terkoneksi ke internet

Baca Juga :  Membuat Router Static 3 Router Cisco

Langkah Seterusnya adalah konfigurasi ospf area dan ospf network

  • Router 1 / R-1 : Konfigurasi OSPF Area dan OSPF Network

[admin@MikroTik] > /routing ospf network add network=192.168.18.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.1.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.3.0/24 area=backbone

  • Router 2 / R-2 : Konfigurasi OSPF Area dan OSPF Network

[admin@MikroTik] > /routing ospf network add network=192.168.14.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.1.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.2.0/24 area=backbone

  • Router 3 / R-3 : Konfigurasi OSPF Area dan OSPF Network  

[admin@MikroTik] > /routing ospf network add network=192.168.15.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=192.168.16.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=192.168.17.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.2.0/24 area=backbone
[admin@MikroTik] > /routing ospf network add network=10.10.3.0/24 area=backbone

Sampain pada tahap ini konfigurasi talah selesai anda bisa langsung cek ke IP Route anda pada setiap router nya. Maka akan tampil ADo atau Active, Dynamic, ospf. Atau dengan melakukan checking neighbor dengan perintah /routing ospf neighbor pr pada setiap routernya.

 [admin@MikroTik] > /routing ospf neighbor pr
0 instance=default router-id=1.1.1.1 address=10.10.3.1 interface=ether4 priority=1 dr-address=10.10.3.1
backup-dr-address=10.10.3.2 state=”Full” state-changes=5 ls-retransmits=0 ls-requests=0 db-summaries=0
adjacency=21m31s

1 instance=default router-id=2.2.2.2 address=10.10.2.1 interface=ether3 priority=1 dr-address=10.10.2.1
backup-dr-address=10.10.2.2 state=”Full” state-changes=5 ls-retransmits=0 ls-requests=0 db-summaries=0
adjacency=1h57m1s

Bagaimana gan, itu adalah Konfigurasi Routing OSPF Pada Mikrotik, Lumayankan ! Nanti anda bisa coba coba mungki ndengan 4 router, 5 router  atau mungkin lebih sampai komputer anda hang hehehhehe.
Selamat mencoba gan..
Sekian dan Terima Kasih !

Azhari Sikumbang

Tulis dan bicarakan, agar lebih berguna. (Github | Linked in)
~ azhari@coretanit.com